написать программу, которая меньшее возводит в квадрат, а большее оставляет без изменений

0 голосов
85 просмотров

написать программу, которая меньшее возводит в квадрат, а большее оставляет без изменений


Информатика (97 баллов) | 85 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
Паскаль

Var 
a,b:real;
Begin
write('a='); readln(a);
write('b='); readln(b);
if (aelse b:=sqr(b);
writeln('a=',a,' b=',b);
End.
(8.6k баллов)
0 голосов

Если на паскале
program qweqrq;
var a,b,c:integer;
begin
writeln('a');
readln(a);
writeln('b');
readln(b);
if athen
begin
c:=sqr(a);
 writeln(c);
end;
else
begin
c:=sqr(b);
writeln(c);
end;
end.


(148 баллов)
0

Var a,b:integer;
Begin
write('a='); readln(a);
write('b='); readln(b);
if athen
begin
c:=sqr(a);
writeln(c);
end;
else
begin
c:=sqr(b);
writeln(c);
end;
end.

0

а зачем тебе переменная с?

0

Var
a,b:integer;
Begin
write('a='); readln(a);
write('b='); readln(b);
if (a else b:=sqr(b);
writeln('a=',a,'b=',b);
end.

0

тоже самое, только без лишнего

0

твой код не удобно читать, пиши нормально в след раз, зачем ты каждую операцию пишешь с новой строки?

0

И ещё одно замечание: в данной задаче лучше использовать вещественные числа real т.к. если я введу в твою программу числа 2.4 и 2.2, то твоя программа вылетит и не даст результата

0

столько нарушений нашел, но ни одного по делу