Составить программу в паскале Массив задан датчиком случайных чисел ** интервале [-37,...

0 голосов
81 просмотров

Составить программу в паскале
Массив задан датчиком случайных чисел на интервале [-37, 66]. Найти наибольший и наименьший элементы и их номера. Размер массива произвольный, но не больше 100


Информатика (25 баллов) | 81 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-37,66); a.Println;
  var (imin,imax):=(a.IndexMin,a.IndexMax);
  Writeln('Минимальный элемент №',imin+1,' равен ',a[imin]);
  Writeln('Максимальный элемент №',imax+1,' равен ',a[imax]);
end.

Пример
n= 17
17 21 49 -2 49 30 -3 39 11 20 65 -28 10 14 -30 11 -1
Минимальный элемент №15 равен -30
Максимальный элемент №11 равен 65

image
(150k баллов)
0

не работает программа...

0

Program z45;
Var a: array[1..100] of integer;
i, n, max, min, c: integer;
Begin
Write ('Сколько элементов? ');
Readln (n);
a[i]:=Random(104)-37;
c:=i;
min:=c;
max:=c;
For i:=1 to n do
begin
a[i]:=Random(104)-37;
c:=i;
if cif c>max then max:=c;
end;
writeln(max);
writeln(min);
End.

0

можете проверить,в чём тут ошибка? я не совсем просто понимаю..