Напишите программу ** языке PascalABC.NET

0 голосов
29 просмотров

Напишите программу на языке PascalABC.NET


image

Информатика (3.5k баллов) | 29 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (fact,eps,s,x):=(1.0,0.001,0.0,1);
  while true do begin
    fact:=fact*x;
    var a:=Power(2/x,x)*fact;
    if Abs(a)>eps then begin x+=1; s+=a end
    else Break
    end;
  Writeln('S = ',s:0:3)
end.

Результат
S = 12.946
(150k баллов)