Ниже записана программа. Получив ** вход число x , эта программа печатает два числа, L и...

0 голосов
195 просмотров

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7.

var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:= L + 1;
if x mod 2 = 1 then
M:= M + (x mod 10) div 2;
x:= x div 10;
end;
writeln(L); write(M);
end.


Информатика (19 баллов) | 195 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

В L =3 - количество цифр в чмсле
в M=7 - сумма  целых частей двух нечётных цифр, делённых на два
7=4+3;  цифры (нечётные)  9 и 7
одна из цифр числа должна быть чётной, мах чётная цифра  это 8
из цифр 9, 7, 8 составляем наибольшее число, оно = 987
ответ 987

(87.0k баллов)