Ниже записана программа. Получив ** вход число x, она печатает два числа. Укажите...

0 голосов
50 просмотров

Ниже записана программа. Получив на вход число x, она печатает два числа. Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 10.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:=L+1;
if (M < x) and (x mod 2 = 1) then begin
M:= (x mod 10) * 2;
end;
x:= x div 10;
end;
writeln(L); write(M);
end.


Информатика (15 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

 L=2 -   количество цифр в числе Х
М=10 - (последняя цифра числа Х)*2---->
                                                        (последняя цифра числа Х)=10:2=5
мах Х=95              ответ 95

(87.0k баллов)