Ребят, будте добры написать программу ** паскале. Условие: надо написать программу,...

0 голосов
34 просмотров

Ребят, будте добры написать программу на паскале. Условие: надо написать программу, которая решает квадратное уравнение. (используя goto)


Информатика (12 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
var
a,b,c,x1,x2,d:real;
begin
write('Введите A='); readln(a);
write('Введите B='); readln(b);
write('Введите C='); readln(c);
D:=b*b-4*a*c;
if D<0 then begin<br>writeln('Нет корней');
end;
if D=0 then begin
writeln('x1=',-b/(2*a))
end;
if D>0 then begin
x1:=(-b-sqrt(d))/(2*a);
x2:=(-b+sqrt(d))/(2*a);
writeln('x1=',x1);
writeln('x2=',x2);
end;
end.
(56 баллов)
0

C goto

0

GOTO