Пожалуйста помогите, надо сдавать работу ! Написать программу ** языке С++ В заданном...

0 голосов
33 просмотров

Пожалуйста помогите, надо сдавать работу !
Написать программу на языке С++
В заданном одномерном массиве поменять местами соседние элементы, стоящие на чётных местах, с элементами, стоящими на нечётных.


Информатика (343 баллов) | 33 просмотров
0

а если количество элементов - нечетное число? Что делать с последним?

0

при вводе сделаю четное количество элементов

Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
using namespace std;
int main(){
int n = 10;
int arr[n];
for(int i = 0; i < n; ++i){
arr[i] = rand() % 300 - 150;
cout << arr[i] << " ";<br>}
cout << endl;<br>/*Начало важной части*/
for(int i = 0; i < n/2; ++i){
int buff = arr[2*i];
arr[2*i] = arr[2*i+1];
arr[2*i+1] = buff;
}
/*Конец важной части*/
cout << "Result: ";<br>for(int i = 0; i < n; ++i)
cout << arr[i] << " ";<br>cout << endl;<br>system("pause");
return 0;
}

(7.0k баллов)
0

error 'system' was not declared in this scope в 20 строке

0

где пишешь код?

0

codeblocks

0

пробуй

0

обе эти функции не особо важны

0

всё работает, спасибо

0

а нельзя значения самому ввести?

0

Можно. Но моя задача, дать тебе код, который меняет элементы местами.

0

Он отмечен как "важная часть"

0

Все остальное - мешура, чтобы показать, как работает код.