python. Напишите программу, которая переставляет соседние элементы массива: 1-й со 2-м,...

0 голосов
278 просмотров

python.
Напишите программу, которая переставляет соседние элементы массива: 1-й со 2-м, 3-й с 4-м и т.д. Нумерация элементов начинается с единицы.

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.


Информатика (12 баллов) | 278 просмотров
Дан 1 ответ
0 голосов

N = int(input())
a = input().split()
for i in range(0, n - n % 2, 2):
    a[i], a[i + 1] = a[i + 1], a[i]
print(' '.join(a))

(18.3k баллов)
0

Только вот проблема в том, что в Python нумерация начинается с 0.