Напишите программу, которая формирует случайным образом формирует одномерный массив...

0 голосов
55 просмотров

Напишите программу, которая формирует случайным образом формирует одномерный массив размером 50 из целых чисел из интервала [-30...30], а затем определяет количество положительных чисел в массиве.


Информатика (16 баллов) | 55 просмотров
0

Какой язык?

Дан 1 ответ
0 голосов

Программа написана для Pascal

const n=50;
var a:array[1..n] of integer;
      i,k:integer;
begin
for i:=1 to n do begin
a[i]:=RANDOM(61)-30;
write(a[i],' ');
end;
k:=0;
for i:=1 to n do
if a[i]>0 then k:=k+1;
writeln('количество положительных чисел массива=',k);
end.

(90 баллов)