Напишите программу для работы с массивом позволяющую 1)Создать массив из 16 элементов...

0 голосов
23 просмотров

Напишите программу для работы с массивом позволяющую
1)Создать массив из 16 элементов целого типа, при описании количество элементов использовать именованную константу.
2)заполнить массив случайными числами, не превосходящими 20
3) вывести массив на экран в строку
4) подсчитать количество элементов, меньших 11


Информатика (150 баллов) | 23 просмотров
Дан 1 ответ
0 голосов

Program NekitZor;
const
n=16;//1-Именованная переменная количество елементов 
var 
a:array[1..n] of integer;
k:integer;
i:integer;
begin
for i:=1 to n do
a[i]:=random(20);//2-Массив чисел, задал рандомно не больше 20
for i:=1 to n do write(a[i],'    ');//3-Вывел массив в строку
for i:=1 to n do 
if a[i]<11 then k:=k+1;//4-Подсчитал количество елементов меньше 11<span>
writeln();
writeln();
writeln('Количество елементов меньше 11 = ',k);
end.



image
(610 баллов)