Помогите написать программу ** С++( 2 способами) Задание во вложении

0 голосов
30 просмотров

Помогите написать программу на С++( 2 способами)
Задание во вложении


image

Информатика (5.5k баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//1) WHILE

#include
using namespace std;
int main() {
    int n = 30;
    int sum = 0;
    while (n <= 70) {<br>        if (n % 4 == 0) sum = sum + n;
        n++;
    }
    cout << "Sum = " << sum << endl;<br>    system("pause");
    return 0;
}

//2) DO WHILE
#include
using namespace std;
int main() {
    int n = 30;
    int sum = 0;
    do {
        if (n % 4 == 0) sum = sum + n;
        n++;
    } while (n <= 70);<br>    cout << "Sum = " << sum << endl;<br>    system("pause");
    return 0;
}

(9.4k баллов)