Написать программу решения уравнения ax3+bx=0 для произвольных a, b. помогите))плииииз!!

0 голосов
181 просмотров

Написать программу решения уравнения ax3+bx=0 для произвольных a, b. помогите))плииииз!!


Информатика (17 баллов) | 181 просмотров
0

ах в кубе если что

Дан 1 ответ
0 голосов
Правильный ответ

Var 
a,b,x1,x2:real; 
begin 
Read(a);readln(b);
if (a*b>0) and( b<>0) then writeln(-2*sqrt(b),' ',2*sqrt(b),' ','0'); else writeln('0');
end.

(862 баллов)