Написать программу , которая n раз выводит ** экран ** одной строке имя и фамилию, **...

0 голосов
254 просмотров

Написать программу , которая n раз выводит на экран на одной строке имя и фамилию, на другой строке дату рождения.
Надо сравнить.


Информатика (112 баллов) | 254 просмотров
0

С моей полученной программой

0

Для наглядности посмотреть

Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1576 от 16.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите имя и фамилию:');
  var g:=ReadlnString('Введите год рождения:');
  var n:=ReadInteger('Сколько раз повторить вывод?');
  loop n do Writeln(s,NewLine,g)
end.

Пример
Введите имя и фамилию: Иванов Сергей
Введите год рождения: 24.06.2001
Сколько раз повторить вывод? 3
Иванов Сергей
24.06.2001
Иванов Сергей
24.06.2001
Иванов Сергей
24.06.2001

(150k баллов)
0

Извините, упустила

0

Мы не проходили еще LOOP

0

Хорошо, поищу в интернете по этой теме

0

Спасибо

0 голосов

Var first_name, data : string;i : byte; n : integer;
begin  write('Введи свое имя и фамилию: ');  readln(first_name);  write('Ведите свою дату ррождения: ');  readln(data);  readln(n);  for i := 1 to n do  write(first_name, ' ');  writeln(' ');  for i := 1 to n do  write(data, ' ');end.

(396 баллов)
0

Немного не так, но спасибо)

0

Я не особо проф по паскалю. Есть лишние строчки и код возможно можно было бы и сократить, но лавное, что работает C:

0

Работает не совсем неправильно

0

в каком месте?

0

Нет кол-ва раз у вас в программе

0

n же

0

В Паскале не работает это

0

у меня все работает. Я же проверил перед тем как отправить...

0

Да? Странно?

0

Странно.