Напишите программу, которая получает два целых числа и находит их произведение, не...

0 голосов
145 просмотров

Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными только на С++


Информатика | 145 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

int main()

{
    int n, m;
    cin >> n >> m;
    int ans = 0;
    if (n != 0 && m!=0)
    for (int i = 0; i < abs(m); i++)
    ans += n;
    if (n != 0 && m!=0) cout << ans / (abs(m)/m);<br>    else cout << 0;<br>}



(8.8k баллов)