Напишите программу для суммы числового ряда. Дан числовой ряд и малая величина е(эпсила)....

0 голосов
55 просмотров

Напишите программу для суммы числового ряда.
Дан числовой ряд и малая величина е(эпсила). Найдите сумму ряда с точностью е(0,001), общий член которого задан формулой:
a = \frac{ {2}^{x} \times x! }{ {x}^{x} }


Информатика (3.5k баллов) | 55 просмотров
0

т9, что поделать) Самому смешно

0

Вы мне поможете?

0

ОК

0

Да

Дан 1 ответ
0 голосов
Правильный ответ

//Pascal
//Функция факториала
function fact(n: integer): real;
begin
  if (n = 0) then fact := 1
  else fact := n * fact(n - 1);
end;

//Main
var
  a: real;
  x, lim: integer;
begin
  write('Введите x: '); readln(x);
  lim := x; a := 0;
  for x := 1 to lim do
  begin
    //a := a + (power(2, x) * fact(x))/(power(x, x));
    a := a + ((exp(ln(2) * x)) * fact(x))/(exp(ln(X) * x));    
  end;
  writeln('a = ', a:5:3);
  readln;
end


image
(9.4k баллов)
0

у вас на каком языке программирования записано?

0

Free Pascal. Если делаешь на PascalABC.NET, можешь убрать комментарий со строчки "//a := a + (power(2, x) * fact(x))/(power(x, x));" , а строчку "a := a + ((exp(ln(2) * x)) * fact(x))/(exp(ln(X) * x));" убрать вовсе. Если тебе надо на другом языке, то это надо указывать в задании.

0

Спасибо большое