ПРОШУ ПОМОГИТЕ, ОЧЕНЬ НУЖНО!! ИНФОРМАТИКА 10 КЛАСС, PASCAL. Дана строка, содержащая два...

0 голосов
41 просмотров

ПРОШУ ПОМОГИТЕ, ОЧЕНЬ НУЖНО!!
ИНФОРМАТИКА 10 КЛАСС, PASCAL.
Дана строка, содержащая два слова, разделенные дефисом. написать программу, добавляющую пробел до и после дефиса


Информатика (15 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString;
  var p:=Pos('-',s);
 if p>0 then begin s:=s.Replace('-',' - '); Writeln(s) end
  else Writeln('Дефис не найден')
end.

Пример
черно-белый
черно - белый

(150k баллов)