Составьте программу, по которой компьютер десять раз запросит ввод целых чисел и в...

0 голосов
86 просмотров

Составьте программу, по которой компьютер десять раз запросит ввод целых чисел и в результате сообщит, сколько среди введенных чисел четных и сколько нечетных


Информатика (18 баллов) | 86 просмотров
0

Я так понимаю массив?

0

Да

Дан 1 ответ
0 голосов

Var a:array[1..10] of integer;

b,c,i:integer;

begin

 writeln('Write 10 numbers:');

 for i:=1 to 10 do

  read(a[i]);

 b:=0;

 c:=0;

 for i:=1 to 10 do

  if a[i] mod 2=0

   then b:=b+1

   else c:=c+1;

 writeln('Even numbers:',b); // Четных

 writeln('Odd numbers:',c);  // Нечетных

 readln

end.


(5.8k баллов)
0

Спасибо огромное! =)