Написать программу в Pascal. Высота саженца 20 см. Естественный ежегодный прирост 15%....

0 голосов
52 просмотров

Написать программу в Pascal.
Высота саженца 20 см. Естественный ежегодный прирост 15%. Через сколько лет высота достигнет 500 см?


Информатика (20 баллов) | 52 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var h: real;
      n: integer;
begin
   h:=20; n:=0;
   repeat
      h:=h*1.15;
      n:=n+1;
    until h>=500;
    writeln(n,' года');
end.

24 года

(9.7k баллов)
0

Спасибо.