Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в...

0 голосов
135 просмотров

Составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы используя операторы цикла While, Repeat и For.


Информатика (18 баллов) | 135 просмотров
Дан 1 ответ
0 голосов

1) С помощью while:
var

a,b,c,i:integer;

begin

 i:=0;

 b:=0;

 writeln('Write 10 number:');

 while i<10 do<br>
  begin

   read(a);

   b:=b+a;

   i:=i+1;

 end;

 writeln('Average: ',b/10:0:0);

 readln

end.

(5.8k баллов)
0

Ща остальные будут

0

2) С помощью repeat

0

var
a,b,c,i:integer;
begin
i:=0;
b:=0;
writeln('Write 10 number:');
repeat
read(a);
b:=b+a;
i:=i+1;
until i=10;
writeln('Average: ',b/10:0:0);
readln
end.

0

3) С помощью for

0

var
a,b,c,i:integer;
begin
b:=0;
writeln('Write 10 number:');
for i:=1 to 10 do
begin
read(a);
b:=b+a;
end;
writeln('Average: ',b/10:0:0);
readln
end.

0

Спасибо!)