Написать программу Паскаль -перенести первое число в конец Число трехзначное Помогите:)

0 голосов
29 просмотров

Написать программу Паскаль -перенести первое число в конец
Число трехзначное
Помогите:)


Информатика (19 баллов) | 29 просмотров
0

То есть?) Первую цифру поменять с последней?)

0

да то есть например 456 то должно 564

Дан 1 ответ
0 голосов

Прошу:)

var a, b, c, d: integer;
begin
     readln(d);
     a := d div 100;
     b := d mod 100 div 10;
     c := d mod 10;
     writeln(b, c, a);
end.

можно ещё сократить:
var a, b, c, d: integer;
begin
     readln(d);
     writeln(d mod 100 div 10, d mod 10, d div 100);
end.

или даже:
var a, b, c, d: integer;
begin
     readln(d);
     a := d div 100;
     writeln(d - a * 100, a);
end.

(16.9k баллов)
0

Сколько угодно решений можно придумать:)