Написать программу в C++ Найти все простые числа в заданном пользователем диапазоне [a;...

0 голосов
89 просмотров

Написать программу в C++ Найти все простые числа в заданном пользователем диапазоне [a; b].


Информатика (819 баллов) | 89 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
using namespace std;
bool prost(int m){
int k = 0;
for (int i=2; i<=sqrt(m); i++)<br> if (m % i == 0) k++;
return k==0;
}

int main(){
    int a, b;
    cin >> a >> b;
    for (int i=a; i<=b; i++)<br>     if (prost(i)) cout << i << " ";<br>    return 0;
}

Пример:
5 20
5 7 11 13 17 19

(194k баллов)
0

Выдаёт все числа, а не только простые

0

Этого не может быть. Проверяйте ещё раз.