Задание: написать программу, которая выведет ** экран таблицу умножения (через оператор...

0 голосов
40 просмотров

Задание: написать программу, которая выведет на экран таблицу умножения (через оператор while)(всю), типа: 2*2=4;2*3=6...8*9=72;9*9=81. Язык- Pascal ABC.


Информатика (20 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

Var
    n, i: integer;

begin
    n := 0;
    while (n <= 1) or (n > 10) do
    begin
        write('Введите n в диапазоне от 2 до 10 = ');
        readln(n);
    end;
   
    for i := 1 to 9 do
        writeln(n, ' * ', i, ' = ', n * i);
end.

без проверки

var
    n, i: integer;

begin
    write('Введите n в диапазоне от 2 до 10 = ');
    readln(n);
   
    for i := 1 to 9 do
        writeln(n, ' * ', i, ' = ', n * i);
end.

(138 баллов)
0

Мне надо через while

0

while (n <= 1) or (n > 10) do

0

А, нашел, спасибо, но мне б всю таблицу (как на тетрадях в клетку сзади)

0

по анологии подставь свои значения)

0

А for обязателен? Препод сказал, чтобы только через while...

0

конечно

0

while же пресудствует

0

Мне задали только через while