Помогите пожалуйста написать программу в Паскаль! 1) Вывести n целых случайных чисел из...

0 голосов
22 просмотров

Помогите пожалуйста написать программу в Паскаль!
1) Вывести n целых случайных чисел из промежутка от 0 до 10
2)Вычислить сумму чисел из промежутка от 1 до 10


Информатика (45 баллов) | 22 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!

1)

begin
  SeqRandom(Readinteger,0,10).Println
end.

Пример
13
7 5 6 8 9 9 4 5 7 3 1 7 10

2)

begin
  Writeln(1.To(10).Sum)
end.

Результат
55
(150k баллов)
0 голосов

1)
var n,i:integer;
begin
readln(n);
for i:=1 to n do write(random(11),' ');
end.

Пример:
10
5 2 9 5 7 2 10 0 1 6

2.
var s,i:integer;
begin
s:=0;
for i:=1 to 10 do s:=s+i;
write('s = ',s);
end.

Результат:
s = 55

(194k баллов)