Напишите программу, которая заполняет массив из N элементов членами арифметической прогрессии с начальным значением X и разностью D . Входные данные Входная строка содержит три целых числа: начальное значение X , разность D и размер массива N , разделённые пробелом. Гарантируется, что 0 < N ≤ 10000 . Выходные данные Программа должна вывести содержимое массива: N первых членов арифметической прогрессии с начальным значением X и разностью D . Примеры входные данные 8 4 5 выходные данные 8 12 16 20 24
#include #include using namespace std; int main() { int x,d,n; cin >>x>>d>> n; vector v(n); v[0] = x; for (int i = 1;i{ v[i] = v[i - 1] + d; } for (int i = 0; i < n; i++) { cout<<v[i]<<' ';<br>} return 0;}
Спасибо, только это какой язык? Мне просто нужен Паскаль ABC
Это C++