** ПАСКАЛЕ!!! 1. Написать программу которая будет выводить сумму четных цифр(пока не...

0 голосов
44 просмотров

НА ПАСКАЛЕ!!! 1. Написать программу которая будет выводить сумму четных цифр(пока не введете 0). 2.Программа выводит количество четных цифр. 3.Программу которая будет выводить произведение введенных чисел пока не будет введен 0.


Информатика (53 баллов) | 44 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Sum)
end.

Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
2708

begin
  Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Count)
end.

Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
5

begin
  Writeln(ReadSeqIntegerWhile(t->t<>0).Aggregate(Biginteger(1),(x,y)->x*y))
end.

Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
-775118121479521866390147967800000
(150k баллов)
0

Причем тут виноват, я же ничего не говорю про это..... Зачем спорить с вами если очевидно что это правильно, просто я повторюсь что мне нужно было что-бы программа была написан на с использованием выше приведенных операторов. Все равно спасибо.

0

Я не могла его изменить, кнопка пропала.

0

Такой ...... Слов нету, я ничего про тебя не говорю, так что следовало бы просто закрыть рот и пройти мимо... Нет нужно поэму написать прежде чем уйти.