Написать программу в паскале Проверить является ли введенное число четным

0 голосов
117 просмотров

Написать программу в паскале
Проверить является ли введенное число четным


Информатика (239 баллов) | 117 просмотров
Дано ответов: 2
0 голосов

Program cht; //Название программы
var a: integer; //Описание переменных
Begin //Начало программы   
Writeln ('Введите число'); //Диалог с пользователем   
Readln (a); //Считывание числа   
if a mod 2 = 0 then //Проверка на чётность writeln ('Это число чётное') //Вывод, если чётное   else //Иначе   
writeln ('Число нечётно'); //Вывод на нечётное end. //Конец программы

(207 баллов)
0 голосов

Program p_1; 
Uses Crt;
var 
n, pr: integer;
begin
write('Введите число: ');
readln(n);
if n mod 2=0 then
writeln('Число четное')
else writeln('Число нечетное');
readln;
end.

(7.8k баллов)