Напишите программу, которая шифрует тексты следующим образом: Исходная строка разбивается...

0 голосов
33 просмотров

Напишите программу, которая шифрует тексты следующим образом: Исходная строка разбивается на части по 4 символа и эти четыре символа перемещаются по кругу влево на одну позицию. Если последняя группа символов состоит из 1, 2 или 3 символов, то они остаются неизменными.


Информатика (25 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
#include
using namespace std;
int main(){
setlocale(LC_ALL, "Russian");
cout << "Введите строку: ";<br>string line; cin >> line;
for(int i = 0; i < line.length()/4; ++i){
char buff = line[4*i];
line[4*i]=line[4*i+1];
line[4*i+1]=line[4*i+2];
line[4*i+2]=line[4*i+3];
line[4*i+3]=buff;
}
cout << "Ответ: " << line << endl;<br>system("pause");
return 0;
}

(6.9k баллов)