Помогите с Пасклем! ** вход программе подаются три целых числа a, b, c – длины сторон...

0 голосов
43 просмотров

Помогите с Пасклем!
На вход программе подаются три целых числа a, b, c – длины сторон треугольника. Вывести значение площади данного треугольника. Гарантируется, что с введёнными длинами сторон треугольник существует. Можно использовать любой способ нахождения площади треугольника.


Информатика (60 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer; p,s:real;
begin
readln(a,b,c);
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('s = ',s:5:2);
end.

Пример:
3 4 5
s = 6.00

(194k баллов)