Помогите , пожалуйста . Нужно написать программу для Паскаль.Ввести пять чисел и найти...

0 голосов
123 просмотров

Помогите , пожалуйста . Нужно написать программу для Паскаль.

Ввести пять чисел и найти наибольшее из них.
Я тут написал кое-что ,но не знаю правильно ли :(
HELP ME.

program ru;
var a,b,c,d,e,max:integer;
begin
writln('Введите пять целых чисел');
if a>b then
begin
max:=a;
end
else begin
max:=b;
end;
if max>c then
begin
max:=max;
else begin
max:=c;
end;
if d>e then begin
max:=d;
end
else begin
max:=e;
end.


Информатика (44 баллов) | 123 просмотров
Дан 1 ответ
0 голосов

Program ru;
var a,b,c,d,e,max:integer;
begin
writeln('Введите пять целых чисел');
readln(a,b,c,d,e);
max:=a;
if b>max then
max:=b;
if c>max then
max:=c;
if d>max then
max:=d;
if e>max then
max:=e;
writeln('Наибольшее число равно ', max);
end.

(8.2k баллов)
0

Не , мне нужно пока что сделать так , как я написал ) Просто мы этого не проходили , а объяснить что это такое я не смогу .

0

Понятно)

0

Сейчас исправлю

0

О , спасибо