Дан массив из n элементов.Написать программу, уменьшающую все элементы массива ** еденицу

0 голосов
38 просмотров

Дан массив из n элементов.Написать программу, уменьшающую все элементы массива на еденицу


Информатика (12 баллов) | 38 просмотров
Дан 1 ответ
0 голосов
var
  A: array [1..10] of integer;
  i, n: integer;
begin
  for i := 1 to 10 do
  begin
      write('Введите A[', i, '] = ');
      readln(A[i]);
  end;
  writeln('Ваш массив.');
  for i := 1 to 10 do
    write(A[i]:4);
  writeln('Все элементы массива были уменьшены на 1.');
  for i := 1 to 10 do
  begin
      A[i] := A[i] - 1;
      write(A[i]:4);
  end;
end.

image
(9.4k баллов)
0

Блин, есть строки, которые мы даже еще не учили(

0

Какие например? Попробую переделать.

0

Byte SetLength randomize

0

Отредактировал. Byte поменял на integer. Randomize нужен для заполнения массива случайными числами. Сейчас сделал заполнение с клавиатуры(см. картинку). SetLength нужен был для того, чтобы можно было с клавиатуры задать размер массива(по условию "Дан массив из n элементов"? т.е. n вводилась с клавиатуры. Сейчас убрал это и сделал массив размером в 10 элементов.

0

Спасибо большое!Просто я, да и в целом класс не шарим в информатике)