В этом году третий раз одна известная компания проводит соревнование по программированию...

0 голосов
113 просмотров

В этом году третий раз одна известная компания проводит соревнование по программированию искусственного интеллекта для игровых стратегий. В этот раз участникам предложили написать искусственный интеллект для управления командой хоккеистов. Научившись оценивать время, за которое хоккеист сможет догнать шайбу, Вася решил использовать это для улучшения своей стратегии. Оказалось, что не всегда выгодно ехать к шайбе защитнику, так как нападающий соперника может перехватит ее раньше и выйти один на один с вратарем. Чтобы избежать подобных провалов в обороне нужно еще определить, через сколько противник сможет подобрать шайбу. Вася уже вычислил, что первому хоккеисту соперника понадобится для этого A условных единиц времени, а второму — B. Помогите ему подсчитать, через какое наименьшее время противник сможет подобрать шайбу.
Формат ввода

Во входном файле заданы два целых числа A и B (0 ≤ A, B ≤ 109) — за какое время хоккеисты соперника смогут подобрать шайбу.


Информатика (16 баллов) | 113 просмотров
Дано ответов: 2
0 голосов

Блин сам не могу решить

(19 баллов)
0

Спасибо, помог(нет)

0 голосов

program z1;

var

a,b,c:int64;

input,output:text;

begin

 assign(input,'input.txt');

 reset(input);

 assign(output,'output.txt');

 rewrite(output);

 readln(input,a,b);

  begin

   if a

   c:=a else

   c:=b

  end;

 writeln(output,c);

 close(input);

 close(output);

end.






(14 баллов)
0

А что это за язык программирования?

0

Pascal