В магазине акция:скидка 5% ** товары,цена которых превышает 1000руб.Напишите программу(в...

0 голосов
744 просмотров

В магазине акция:скидка 5% на товары,цена которых превышает 1000руб.Напишите программу(в питоне),отчасти имитирующую работу кассы:вводятся цены покупаемых товаров,нужно вывести общую стоимость товаров с учетом скидки.
Форма ввода:несколько действительных чисел-цены на товары. Каждое число записано в отдельной строке. Последнее число-отрицаиельное-сигнал остановки.
формат вывода:одно действительное число- общая стоимость с учетом скидки. Помогите, пожалуйста, направьте хотя бы как while и if совместить или что вообще надо?


Информатика (112 баллов) | 744 просмотров
Дан 1 ответ
0 голосов

>program zadacha;
var
a:integer;
b:real;
begin
writeln('введите сумму покупки');
readln(a);
b:=a;
if a>500 then b:=a/1.03;
if a>1000 then b:=a/1.05;
writeln('сумма покупки с учетом скидки равна:',b);
readln;
end.

(16 баллов)
0

эт не питон(