ПРОГРАММА ** С++ Найдите самый маленький натуральный делитель числа x, отличный от 1 (2...

0 голосов
51 просмотров

ПРОГРАММА НА С++


Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000).<br>
Входные данные
Вводится натуральное число x.

Выходные данные
Выведите наименьший делитель числа x, отличный от 1.

Примеры
входные данные
2
выходные данные
2
входные данные
6
выходные данные
2


Информатика (324 баллов) | 51 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;

int main()
{
    int x, i=2;
    cin >> x;
    while ((x % i != 0)&&(i    cout << i <<endl;<br>    system("pause");
}

Пример:
15
3

(194k баллов)