Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! +3! + ... +...

0 голосов
39 просмотров

Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! +3! + ... + n! (n>1)


Информатика (22 баллов) | 39 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1549 от 17.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=BigInteger(0);
  var f:=BigInteger(1);
  for var i:=1 to ReadInteger('n=') do begin
    f*=i;
    s+=f
    end;
  Writeln('S= ',s)
end.

Примеры
n= 5
S= 153

n= 20
S= 2561327494111820313

n= 100
S= 94269001683709979260859834124473539872070722613982672442938359305624678223479506023400294093599136466986609124347432647622826870038220556442336528920420940313




(150k баллов)