Помогите, пожалуйста, написать программу в паскале!!

0 голосов
64 просмотров

Помогите, пожалуйста, написать программу в паскале!!


image

Информатика (2.6k баллов) | 64 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
    i, k: integer;
    s: real;

begin
    s := 1;
    for i := 1 to 10 do
    begin
        k := k + i;
        s := s * k;
        writeln(i:3,k:3,' ',s);
    end;
    writeln(s);
end.

(53.1k баллов)
0

какой ответ?

0

ой
неправильно чо-то посчитала как всегда

0

скорее всего у Расты ошибка в рассчетах, ведь цифры весьма похожи

0

как и у меня

0

у меня 141455160000

0

если по задаче вычислять, то должно выйти 141455160000

0

должно получиться 144598608000

0

просто складывала и умножала, как и нужно в задании

0

все равно не получается

0

да-да, у вас правильно
спасибо большое!
можете еще посмотреть задачки?
http://znanija.com/task/3974660

0 голосов

Program zadacha;
var
i:integer;
s,p:longint;
begin
  s:=1;
  p:=1;
  for i:=2 to 10 do begin
   p:=p+i;
   s:=s*p;
  end;
  write(s);
end.

(156 баллов)
0

почему получается отрицательное число??

0

переполнение стека

0

real хватает

0

можно попробовать Int64, только нужно использовать free pascal.

0

ясно, спасибо

0

данные больше чем максимальное значение возможное для этого типа и оно переходит в минуса

0

эм?