C++ Написать программу, используя два раза while, которая выдает следующее: * ** *** ****...

0 голосов
39 просмотров

C++

Написать программу, используя два раза while, которая выдает следующее:

*
**
***
****
*****
******
*******
********

Я написал, но не работает. Может найдете ошибку в моей? (ошибка не в синтаксисе, а в выдаче результата)

#include

int main()
{
int verticalDown=0;
int horizontalRight=0;
int countColumns=1;

while(verticalDown<8)<br> {
while(horizontalRight {
std::cout << "*";<br> horizontalRight++;
}
countColumns++;
verticalDown++;
std::cout << "\n";<br> }

return 0;
}


Информатика (20 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

Лучше делать через for
#include using namespace std;

int main()
{
const int N = 8;
char matrix[N][N];
for (int i = 0; i < N; i++) {
for (int j = 0; j < N; j++) {
matrix[i][j] = 0;
if (i > j) {
matrix[i][j] = '*';
}
cout << matrix[i][j] << " ";<br>}
cout << endl;<br>}
return 0;
}

(4.2k баллов)