Составить программу в Pascal, которая в тексте после каждой буквы вставляет заданный...

0 голосов
89 просмотров

Составить программу в Pascal, которая в тексте после каждой буквы вставляет заданный символ (с помощью стандартных процедур)


Информатика (24 баллов) | 89 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1579 от 18.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите текст:');
  var c:=ReadlnChar('Введите букву для вставки');
  var s1:='';
  for var i:=1 to s.Length do begin
    s1+=s[i];
    if s[i]<>' 'then s1+=c
    end;
  Writeln(s1)
end.

Пример
Введите текст: Привет паскалю!
Введите букву для вставки Ы
ПЫрЫиЫвЫеЫтЫ пЫаЫсЫкЫаЫлЫюЫ!Ы
(150k баллов)