Нужно написать программу для ПАСКАЛЬ АВС, (тема: Циклы с пред-пост-условием)что бы...

0 голосов
40 просмотров

Нужно написать программу для ПАСКАЛЬ АВС, (тема: Циклы с пред-пост-условием)что бы программа выводила на экран знак «*» до тех пор, пока не будет введен с клавиатуры знак «0»


Информатика (50 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

Var  a: integer;
begin 
//пред условие
  read(a);
  while a <> 0 do
  begin
    writeln('*');
    read(a);
  end;
end.

=====================

var  a: integer;
begin
  //пост условие
    repeat
     writeln('*');
    read(a);
  until a=0
end.

(3.8k баллов)
0

спасибо