1)напишите программу,которая спрашивает целое число n и считает сумму целых чисел ,сумму...

0 голосов
26 просмотров

1)напишите программу,которая спрашивает целое число n и считает сумму целых чисел ,сумму чётных чисел и сумму нечётных от 1 до n
2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b
(Паскаль)


Информатика (124 баллов) | 26 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
// PascalABC.NET 3.3, сборка 1562 от 02.11.2017

1)
var
i, n , cnt1, cnt2 : integer;
begin 
readln(n); 
for i:= 1 to n do 
begin 
if (i mod 2 = 0) then cnt1:= cnt1 + i 
else cnt2:= cnt2 + i; 
end; 
Writeln('Сумма чисел = ', cnt1 + cnt2); 
Writeln('Сумма не четных чисел = ', cnt1); 
Writeln('Сумма четных чисел = ', cnt2);
end.

2)

var
i, a, b : integer;
begin 
readln(a, b); 
for i:= a to b do 
Write(i*i, ' ');
end.
(8.8k баллов)