Напишите программу, которая шифрует тексты следующим образом: Исходная строка разбивается...

0 голосов
39 просмотров

Напишите программу, которая шифрует тексты следующим образом: Исходная строка разбивается на части по 3 символа и эти три символа перемещаются по кругу вправо на одну позицию. Если последняя группа символов состоит из 1 или 2 символов, то они остаются неизменными
turbo pascal


Информатика | 39 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var s:string; c:char; i:integer;
begin
writeln('Введите строку:');
readln(s);
for i:=0 to length(s) div 3-1 do
 begin
 c:=s[3*i+3];
 s[3*i+3]:=s[3*i+2];
 s[3*i+2]:=s[3*i+1];
 s[3*i+1]:=c;
 end;
writeln(s);
end.

Пример:
Primer, begin, end.iPrrmeb, ieg n,den.

(194k баллов)