Помогите ребят с Паскалем ** кану оценка за четверть пж. Нужно написать программу которая...

0 голосов
24 просмотров

Помогите ребят с Паскалем на кану оценка за четверть пж.
Нужно написать программу которая проверяет у тебя таблицу умножения, машина должна дать 10 примеров и показать результат. Причём чтоб они не повторялись. Мы должны вбивать в конце одно число. Это ответ в каждом примере


Информатика (45 баллов) | 24 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
a,b,i,z:integer;
Begin
ClrScr;
Randomize;
for i:=1 to 10 do
 begin
 a:=random(9)+1;
 b:=random(9)+1;
 write(a,'*',b,' = ');
 readln(z);
 if z=a*b then writeln('Верно!')
 else  writeln('Не верно! ',a,'*',b,' = ',a*b);
 end;
readln;
end.

Пример (для 3 заданий):
6*6 = 36
Верно!
8*3 = 26
Не верно! 8*3 = 24
2*4 = 8
Верно!

(194k баллов)
0 голосов

Program z1;
Uses Crt;
Var
z:integer;
Begin
ClrScr;
writeln('1*2=?');
readln(z);
if z=2 then writeln('Верно!')
else  writeln('Не верно! 1*2=2');
writeln('2*3=?');
readln(z);
if z=6 then writeln('Верно!')
else  writeln('Не верно! 2*3=6');
writeln('3*6=?');
readln(z);
if z=18 then writeln('Верно!')
else  writeln('Не верно! 3*6=18');
writeln('4*7=?');
readln(z);
if z=28 then writeln('Верно!')
else  writeln('Не верно! 4*7=28'); 
writeln('5*9=?');
readln(z);
if z=45 then writeln('Верно!')
else  writeln('Не верно! 5*9=45');
writeln('6*4=?');
readln(z);
if z=24 then writeln('Верно!')
else  writeln('Не верно! 6*4=24');
writeln('7*7=?');
readln(z);
if z=49 then writeln('Верно!')
else  writeln('Не верно! 7*7=49');
writeln ('8*6=?');
readln(z);
if z=48 then writeln('Верно!')
else  writeln('Не верно! 8*6=48');
writeln('9*4=?');
readln(z);
if z=36 then writeln('Верно!')
else  writeln('Не верно! 9*4=36');
writeln('10*8=?');
readln(z);
if z=80 then writeln('Верно!')
else  writeln('Не верно! 10*8=80');
readln;
end.

(7.8k баллов)
0

Ты спаситель(ницы).Спасибо