Написать программу, которая находит сумму первой и третьей цифры трёхзначного числа.

0 голосов
35 просмотров

Написать программу, которая находит сумму первой и третьей цифры трёхзначного числа.


Информатика (23 баллов) | 35 просмотров
Дан 1 ответ
0 голосов

Program Sum;
var   
a,b,c,s: integer;
begin
WriteLn('Введите числа а,в,с');
ReadLn(a,b,c);
s:=a+b+c;
WriteLn('Сумма чисел равна',s);
end. 

(309 баллов)
0

Спасибо, но это программа пишется не таким образом, так необходимо использовать как-то div,mod.

0

Например: определение суммы цифр трехзначного числа: Первая цифра: C1= X \ 100 Вторая цифра: C2= X \ 10 MOD 10 Третья цифра: C3= X MOD 10 Сумма цифр: S = C1 + C2 + C3

0

Окончательный вариант CLS FOR X = 100 TO 999 C1= X \100 С2 =X \10 MOD 10 C3 = X MOD 10 S=C1 + C2 + C3 IF (X MOD 7=0) AND (S MOD 7 =0) THEN PRINT X K = K + 1 END IF NEXT X PRINT “ВСЕГО:”, K END