Программа: pascal abc. Задание: дана строка, написать программу, вставляющую после каждой...

0 голосов
50 просмотров

Программа: pascal abc.

Задание: дана строка, написать программу, вставляющую после каждой точки символ пробела.


Информатика (12 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Var s1,s2:string; i:integer;
Begin
 readln(s1);
for i:=1 to length(s1) do
s2:=s2+s1[i]+' ';
writeln(s2);
readln;
end.

(471 баллов)
0

Разве действие не должно повторяться?

0

for - это действие повторяет

0

сорри не правельно решил, прочитал не так, там после точки, а я сделал после каждого символа)