Язык программирования С# Написать программу решения квадратного уравнения ax^2+bx+c=0 для...

0 голосов
147 просмотров

Язык программирования С#
Написать программу решения квадратного уравнения ax^2+bx+c=0 для 3 случаев, когда:
1)D>0
2D=0
3)D<0


Информатика (868 баллов) | 147 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Using System;
public class Test
{
public static void Main()
{
double a,b,c,D;
Console.WriteLine("программа для решения квадратного уравнения вида ax^2+bx+c=0");
Console.Write("введите a: a=");
a=double.Parse(Console.ReadLine());
Console.Write("введите b: b=");
b=double.Parse(Console.ReadLine());
Console.Write("введите c: c=");
c=double.Parse(Console.ReadLine());
Console.WriteLine("решаем уравнение:");
Console.WriteLine(a+"*x^2+("+b+")*x+("+c+")=0");
D=b*b-4*a*c;
Console.WriteLine("D="+b*b+"-"+"("+4*a*c+")="+D);
if (D<0){ Console.Write("D<0 => нет действительных корней");} else if (D>0)
{
Console.WriteLine("D>0 => уравнение имеет 2 действительных корня");
Console.WriteLine("x1="+(-b+Math.Sqrt(D))/(2*a));
Console.WriteLine("x2="+(-b-Math.Sqrt(D))/(2*a));
} else{
Console.WriteLine("D=0 => уравнение имеет 2 совпадающих корня");
Console.WriteLine("x1=x2="+(-b/(2*a)));
}
}
}

(150k баллов)