Помогите написать программу ** паскале, кто сможет - 25 баллов, задание под номером 15!

0 голосов
47 просмотров

Помогите написать программу на паскале, кто сможет - 25 баллов, задание под номером 15!


image

Информатика (285 баллов) | 47 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

S=a×b/2 → b=2×S/a;
c=√(a²+b²)
P=a+b+c

// PascalABC.NET 3.3, сборка 1561 от 02.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,S):=ReadReal2('Введите катет и площадь:');
  var b:=2*S/a;
  var c:=Sqrt(a*a+b*b);
  var P:=a+b+c;
  Writeln('P=',P)
end.

Пример
Введите катет и площадь: 10.5 30.84
P=28.4057957048505

(150k баллов)