Написать программу, которая вычисляет сумму первых n целых положительных целых чисел....

0 голосов
139 просмотров

Написать программу, которая вычисляет сумму первых n целых положительных целых чисел. Количество суммируемых чисел должно вводиться во время работы программы. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены жирным шрифтом).
Вычисление суммы положительных чисел.
Введите количество суммируемых чисел —> 20
Сумма первых 20 положительных чисел равна 210


Информатика (28 баллов) | 139 просмотров
Дан 1 ответ
0 голосов

program zad4;

uses crt;

var

s,i,n: integer;

 

begin

clrscr;

writeln('Вычисление суммы первых n положительных чисел');

writeln('введите количество суммируемых чисел');

readln(n);

s:=0;

 

for i:=1 to n do

                begin

                If n mod i =0 then

                s:=s+n;

                end;

 

writeln('сумма первых ',n,' положительных чисел равна ',s);

readln;

end.



Попробуй как-то так

(19 баллов)
0

Ошибка в for i:=1 to n do

0

Eror 85