Требуется написать программу, которая считывает числа nn и mm, вычитает 100100 из nn в...

0 голосов
155 просмотров

Требуется написать программу, которая считывает числа nn и mm, вычитает 100100 из nn в случае, если оно больше, чем mm по абсолютной величине (иначе говоря, по модулю), а затем выводит эти числа. Напишите на С ++


Информатика (28 баллов) | 155 просмотров
0

что за числа nn и mm? 100100 в двоичной или десятичной системе

Дан 1 ответ
0 голосов
Правильный ответ
#include
#include
using namespace std;
 
int main()
{
int n, m;
cin >> n >> m;
if (fabs(n)>fabs(m)) n-=100;
cout << n << " " << m << endl;<br> system("pause");
}

Пример:
75 -40
-25 -40
(194k баллов)