Программа ** с++ Напишите программу, которая находит номер максимального элемента...

0 голосов
31 просмотров

Программа на с++

Напишите программу, которая находит номер максимального элемента массива.

Входные данные
В первой строке задается одно натуральное число N, не превосходящее 1000 – размер массива.

Во второй строке вводится N чисел – элементы массива (целые числа, не превосходящие по модулю 1000).

Выходные данные
Вывести одно число – номер максимального элемента в массиве. Если в массиве несколько максимальных элементов, выведите номер любого из них.

Примеры
входные данные
5
5 4 3 2 1
выходные данные
1


Информатика (324 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

#include

using namespace std;

int main() {
int n;
cin >> n;
 short *arr = new short[n];

for (int i = 0; i < n; i++) {
 cin >> arr[i];
}
int max = arr[0];
for (int i = 0; i < n; i++) {
  if (arr[i] > max) {
  max = arr[i];
 }
 }
 cout << max;<br> return 0;}

(732 баллов)