Нужно написать программу в MS Visual C#, помогите пожалуйста.....

0 голосов
50 просмотров

Нужно написать программу в MS Visual C#, помогите пожалуйста..
____________________________________________
Услуги телефонной сети оплачиваются по следующему правилу: за разговоры до А минут в месяц – В рублей за минуту, а разговоры сверх установленной нормы оплачиваются из расчета С рублей за минуту. Требуется написать программу, вычисляющую плату за пользование телефоном для введенного времени разговоров за месяц.


Информатика (48 баллов) | 50 просмотров
Дан 1 ответ
0 голосов

Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;

namespace zn
{
    class Program
    {
        public static void Main(string[] args)
        {
            Console.Write("Введите кол-во минут по тарифу: ");
            int a = Convert.ToInt32(Console.ReadLine());
            Console.Write("Введите цену за минуту по тарифу: ");
            int b = Convert.ToInt32(Console.ReadLine());
            Console.Write("Введите цену за минуту сверх тарифа: ");
            int c = Convert.ToInt32(Console.ReadLine());
            Console.Write("Введите время пользования услугами связи за месяц в минутах: ");
            int d = Convert.ToInt32(Console.ReadLine());
            int res = a > d ? a * b : a * b + (d - a) * c;
            Console.WriteLine("Плата за пользование: " + res);
            Console.ReadKey();
        }
    }
}


(1.5k баллов)