Три точки А(х₁;у₁),В(х₂;у₂),С(х₃;у₃) задаются своими координатами.Написать программу,...

0 голосов
59 просмотров

Три точки А(х₁;у₁),В(х₂;у₂),С(х₃;у₃) задаются своими координатами.Написать программу, которая определяет,какая из этих точек ближе к началу координат.


Информатика (20 баллов) | 59 просмотров
0

координаты вводим с клавиатуры? или можно сразу в программе забить?

0

с клавиатуры вводм

Дан 1 ответ
0 голосов

Var
x1,x2,x3,y1,y2,y3,r1,r1,r3: real;
begin
writeln ('введите координаты A');
readln (x1,y1);
writeln ('введите координаты B');
readln (x2,y2);
writeln ('введите координаты C');
readln (x3,y3);
r1:=sqrt(x1*x1+y1*y1);
r2:=sqrt(x2*x2+y2*y2);
r3:=sqrt(x3*x3+y3*y3);
if (r1<=r2) and (r1<=r3) writeln('точка А ближе');<br>if (r2<=r1) and (r2<=r3) writeln('точка B ближе');<br>if (r3<=r1) and (r3<=r2) writeln('точка C ближе');<br>readln;
end

(30.1k баллов)
0

оооо спасибо

0

тут просто вычисляем длину отрезка, соединяющего эту точку с началом координат, и если отрезок меньше других, значит точка ближе к началу

0

математически я знаю как решать, у меня именно с программированием худо*)